Any Warcraft 3 experts out there?

Discussion in 'Video Games' started by James Louderback, May 19, 2017 at 6:08 AM.

  1. James Louderback

    James Louderback Design Team Skeksi and creator of Nagarl

    Likes Received:
    2,102
    Kaiju Coins:
    396
    hey everyone sorry I'm sorry I haven't been so active lately. I've been busy getting a work visa and a new apartment. But now I should be more active whence again.

    I'm having a terrible time getting Warcraft 3 and it's world editor properly set up. I can run it yeah, but it's not at it's fullest potential.
    It's extremely difficult for me to express what's wrong by typing so I was wondering if anyone would have the time to talk to me over skype or something, talking in real time should solve it so much faster.

    But of course I'll give the gist of what's going on and feel free to leave suggestions in the comments.

    *note: I am not asking for game keys I already have them.

    Background:
    1. I bought wc3 reign of chaos(physical copy) in China. The game works fine and I even uploaded its game key on Blizzard's website so it must not of been a bootleg.

    2. I then must of bought the Frozen Throne (digital copy) from an online resource(the game key egnimatically came in the form of an image) this game key however could not be uploaded to blizzard's site. It says my key is already in use...by whom?

    3. Things worked ok for me but I didn't play around with it too much, I did manage to connect to battle net and make a battle net account with my copies.
    But then my hard-drive started dying

    4. Got a new computer with new hard drive.

    5. Copy pasted wc3's folder from my old hard drive to my new one. The game surprisingly works.

    The problems:
    1.Ok so time for me to make my dream custom map, all I want to do is open up this custom ability map so I can add special custom abilities to my map. Then bam. It said it couldn't open that map in my version of world editor.

    2. So I download an update for wc3, it says my version is zh.cn meaning Chinese...so I try running frozen throne as administrator, connect to battle net, then restart.
    Scary Chinese screen pops up that should translated to updating the game I guess(I was afraid to update it because I believe my English version of the frozen throne prevented it from being in Chinese but maybe the update would revert it to RoC's Chinese text). Stops at either 65% or 85% then proceeds to update at a sludgey crawl. Gets to 100% then nothing happens I can't even click finish. Try again same thing happens.

    3. Try to bypass everything just use the game keys I have download the downloaders for RoC and tFF run RoC first but when it comes time to punch in my cd keys it says the game key is invalid. Closed it but I noticed everything is there in the folder anyway. I open up the editor in my newest wc3 folder and it asked for the game keys, which I then provide it with both RoC and TFT's keys and wowowow it actually works and behold I can actually access that map that was previously unable to. Checked TFT In the new wc3 folder and it works connect to battle net and oh that part doesn't work. I heard I should connect to the router or something but instead I figured an update may just fix it.

    4.So I should of been satified but I got greedy. Thought to myself of trying out that Jass thing I've been hearing about, gave it a shot and wow looks likes it opens this time (previously it wouldn't) buuuuuut it's in RoC mode and doesn't recognize TFT of some reason. Maybe the reason was because I never punched in the game keys officially or something?
    Tried clicking on the Jass TFT logo and it said it couldn't hack a dll or something.

    5. This brings me to the update I tried I thought i could fix all aforementioned problems if I applied the latest wc3 update. I applied it then it tells me it can not find that blasted Warcraft 3 game key. No problem I guess, I just won't update it now. Buuuut it now says the same thing if I try to open any of my Warcraft applications.
    Good God somebody help me I think I'm going to go mad.

    So right now I'm downloading all the Warcraft stuff into my old folder which was the one I copy pasted from my hard drive. Maybe this will have the best of both worlds. I have a back up copy of my Warcraft 3 folder in case anything goes wrong.

    So what I want is this:

    1. My CD keys to work and be recognized, I bought them fair and square...still don't recall where I bought tft from though.

    2. Latest updates, compatible with other people's custom maps.

    3. My game to be in English.

    4. Jass world editor to work and be frozen throne compatible

    5. Battle net accessible

    6. Play Warcraft like a normal human being again.

    What I want to do when all of this mess is dealt with:

    1. I want to make a map to play just between me and friends I send the map to. In my custom map I have downloaded a lot of custom content(I don't want to upload the map online because then I'm assuming I'd have to do hours of tracking down who to credit and other permissions I'm sure).
    So basically play with custom content(models textures spells) with just my friends, how can I do that?

    2. Import spells and units from TTOR without replacing spells and units I've edited already.

    3. Create additional races (like different variants of human teams)

    4. Have an option to select copy and paste multiple units in the editor from one map to another.

    5. I would like to request some custom models, where is the best place to do that?

    Thanks so much to anyone who can help me. If you can help me through instant messaging you can send me a pm and I can give you my skype, wechat, or QQ or email.
     

Share This Page